Беспроводное (3G) подключение к сети

Случай №1. Иногда бывает так, что срочно необходимо где-то организовать доступ в Интернет, хотя физической инфраструктуры нет. То есть, возможность подключиться хотя бы по ADSL отсутствует, а сервис надо предоставить. Примером такого случая может служить открытие какого-то офиса или магазина, проведение мероприятия и так далее. В первом варианте фиксированное соединение может появиться позже, но у нас уже горят сроки открытия. А во втором случае организация фиксированного соединения в принципе может быть нецелесообразна. Что же мы будем делать?

Случай №2. У нас есть фиксированное соединение, однако оно может периодически не работать по самым разным причинам. А наш бизнес завязан на постоянную работу с Интернетом, соответственно отсутствие доступа туда может грозить нам большими убытками. В здании, где мы  находимся, есть только один провайдер, соответственно организовать фиксированное подключение через другого не возможно. Но нам нужен резерв. Снова повторяется вопрос: что же мы будем делать?

А делать мы будем подключение к Интернету через радиосеть оператора мобильной связи, то есть через 3G.

Сегодня сложно найти оператора мобильной связи, который бы не оказывал услуги по доступу в Интернет мобильным пользователям. Оба случая, которые мы описали в начале статьи, не являются мобильными, однако никто не мешает нам воспользоваться возможностью доступа в Интернет через 3G сеть оператора мобильной связи. В маршрутизаторах Cisco, которые обычно используются для установки в небольших офисах, в зависимости от конфигурации может быть 3G модем. Мы ведем речь о маршрутизаторах Cisco 800 Series, 1900/2900 Series. В зависимости от модели, 3G модем может быть:

1)      Встроенным в сам маршрутизатор;

2)      В виде PCEX карты;

3)      В виде HWIC модуля.

Используя один из таких модемов, мы и будем организовывать подключение нашей сети к Интернету. Мы везде упоминаем Интернет, потому что это самая распространенная услуга. На самом деле, беспроводное подключение может осуществляться не к Интернету, а к выделенному APN, организованному оператором мобильной связи, для доступа к  удаленной корпоративной сети пользователя (VPN фактически). Рассматривать будем на конкретном примере, который ты сможешь просто скопировать и немного изменив настроить свой маршрутизатор для указанной задачи. Итак, начнем.

Рисунок 1 / Схема подключения

Рисунок 1 / Схема подключения

На приведенной схеме ты видишь стандартное подключение офиса к сети провайдера. Единственное отличие заключается в интерфейсе подключения – это 3G, а все остальное знакомо до безобразия. С настройки этого знакомого безобразия мы и начнем настройку. В нашем случае был маршрутизатор Cisco 887G, в который встроен 4-х портовый коммутатор, поэтому мы настраиваем SVI (Switch Virtual Interface, для нас – interface Vlan) для подключения локальных рабочих станций:

3GR#configure terminal
3GR(config)#interface Vlan 1
3GR(config-if)#ip address 20.20.20.1 255.255.255.0
3GR(config-if)#interface range fa 0 – 3
3GR(config-if-range)#switchport mode access
3GR(config-if-range)#switchport access vlan 1
3GR(config-if-range)#spanning-tree portfast

Указанной настройкой мы определяем все порты как порты доступа, чтобы ускорить процесс перехода портов в режим передачи трафика (forwarding). Если ты планируешь подключать не рабочие станции, а коммутатор или несколько коммутаторов, то STP отключать не стоит. Далее упрощаем себе жизнь, убирая необходимость настраивать рабочие станции:

3GR(config-if-range)#ip dhcp pool Local_Net
3GR(dhcp-config)#network 20.20.20.0 255.255.255.0
3GR(dhcp-config)#default-router 20.20.20.1
3GR(dhcp-config)#dns-server 8.8.8.8
3GR(dhcp-config)#exit
3GR(config)#ip dhcp excluded-address 20.20.20.1 20.20.20.10

Таким образом, вся настройка, которая касается локальной сети, практически завершена. Остается один небольшой момент, который мы сделаем в конце статьи. В качестве DNS-сервера мы указали один из DNS-серверов Google, хотя можем указать и сервер нашего провайдера.

Дальше перейдем к настройке самого беспроводного подключения к сети. Начнем его с небольшого лирического отступления. 3G интерфейс – это модемное соединение. Это значит, что оно не всегда находится в активном (up) состоянии, а его необходимо активировать и деактивировать. Теоретически, оно, как и ADSL-соединение, может быть всегда активно. Но есть одно «НО» — Интернет-трафик у сотовых операторов ОЧЕНЬ дорогой, соответственно без лишней необходимости лучше соединение не держать поднятым. Потому что небольшое количество служебного трафика постоянно курсирующего между нашим маршрутизатором и точкой доступа оператора может в итоге вылиться в довольно большой объем. Зачем платить лишнее? J На этом лирическое отступление закончено и вернемся к настройке.

Первым пунктом является создание профиля модема, в котором указываются параметры подключения к сети, в том числе: точка доступа, логин, пароль. Эти параметры ты можешь узнать у оператора или посмотреть в своем телефоне. Сама команда выглядит следующим образом:

3GR#cellular 0 gsm profile create 1 vmi.velcom.by ipv4 chap vmi vmi

Настроенный профиль можно просмотреть:

3GR#show cellular 0 profile
Profile 1 = INACTIVE
———
PDP Type = IPv4
Access Point Name (APN) = vmi.velcom.by
Authentication = CHAP
Username: vmi, Password: vmi

Вторым пунктом настройки является создание скрипта дозвона:

3GR(config)#chat-script velcom «» «ATDT*99*1#» TIMEOUT 30 CONNECT

Теоретически этот номер всегда одинаковый, но его можно подсмотреть на сайте провайдера, куда ты подсоединяешься, или уточнить в его техподдержке. (В некоторых операторах, номер будет 98, а не 99. «*1#» в номере означает использование профиля «1», то есть того профиля, который мы создали ранее.

Пункт третий нашей беспроводной истории заключается в настройке самого модема или интерфейса, между маршрутизатором Cisco и модемом:

3GR(config)#line 3
3GR(config-line)#exec-timeout 0 0
3GR(config-line)#script dialer velcom
3GR(config-line)#modem InOut
3GR(config-line)#no exec
3GR(config-line)#transport input all

Команда “modem InOut” означает, что модем будет работать в режиме и приема, и передачи, а команда“script dialer velcom” привязывает созданный скрипт, который надо использовать для подключения.

Так как у нас модем, соответственно соединение надо устанавливать и разрывать. Для того, чтобы установить его в автоматическом режиме, нам необходимо определить какое-то событие, при наступлении которого соединение будет устанавливаться. Таким событием является трафик от локальных рабочих станция (по аналогии с interesting traffic в IPSec VPN), который мы определяем списком доступа (access-list):

3GR(config)#interface Cellular0
3GR(config-if)#ip address negotiated
3GR(config-if)#encapsulation ppp
3GR(config-if)#load-interval 60
3GR(config-if)#dialer in-band
3GR(config-if)#dialer string velcom
3GR(config-if)#dialer-group 1
3GR(config-if)#async mode interactive
3GR(config-if)#ppp ipcp dns request

Протокол канального уровня – ppp, IP-адрес интерфейса и DNS-сервера мы получаем от провайдера. Для установки соединения используется скрипт «velcom», а трафик, который активирует соединение, определяется 1-ым списком dialer-list.

После создания беспроводного интерфейса необходимо создать маршрут по умолчанию через него, который будет показывать куда передавать трафик, после того как тот попал на маршрутизатор:

3GR(config)#ip route 0.0.0.0 0.0.0.0 Cellular0

Должно было бы уже все начать работать, но при текущей настройке линк будет флапать. Понять причину, почему не все работает корректно, помогает дебаг (debug ppp negotiation и debug ppp packets), вывод которого указывает на то, что маршрутизатор не может пройти аутентификацию вследствие того, что поля логин/пароль пустые. Этот недостаток исправляется дополнительной настройкой интерфейса:

3GR(config)#interface Cellular0
3GR(config-if)#ppp chap hostname vmi
3GR(config-if)#ppp chap password 0 vmi

После этого интерфейс переходит в активное состояние, получает IP-адрес от провайдера и начинает полноценно работать. Возможно, профиль некорректно обрабатывается, или настройки оттуда нужны для каких-то других целей. Остается добавить финальный штрих к настройке, чтобы Интернетом могли пользоваться рабочие станции, а не только маршрутизатор. Этот финальный штрих – NAT:

3GR(config)#ip nat inside source list 1 interface Cellular0 overload
3GR(config)#interface Vlan 1
3GR(config-if)#ip nat inside
3GR(config-if)#interface Cellular 0
3GR(config-if)#ip nat outside

Вуаля. Маршрутизатор работает как часы, предоставляя через 3G доступ в Интернет счастливым пользователям. Дальше можно прикручивать к нему различные функции безопасности, такие как фильтрация трафика, файрвол и так далее. Однако это уже совсем другая история.


Комментарии:

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Можно использовать следующие HTML-теги и атрибуты: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Hide me
Получать регулярно свежие материалы, лабораторные и вебинары
Email Имя
Show me