Cisco Fabric Extender и способы их подключения.

Добрый день!

Сегодня хотелось бы поговорить о модульности cisco nexus.
Как вы знаете или может слышали, cisco nexus серий 5000, 7000, 9000 не просто коммутаторы с фиксированным количеством портов, а коммутаторы, к которым можно подключать модули, так называемые расширения cisco FEX (Cisco Fabric Extender). Модули – это коммутаторы cisco nexus серии 2200, которые подключаются и полностью управляются основными устройствами из серий 5000,7000,9000. То есть располагая extenders в разных стойках и подключая их к основному устройству мы получаем огромный единый логический коммутатор.

Хотел бы акцентировать ваше внимание на двух важных заметках:
1) Сами по себе FEX не маршрутизируют и не пересылают пакеты в рамках FEX, все это происходит только через управляющее устройство.
2) К FEX устройствам не получится подключить, по умолчанию на портах активирован BPDU Guard, который нельзя отключить.

N5N(config-if)# spanning-tree port type normal
ERROR: Command not supported on fex port

Кстати, в новых линейках оборудования для корпоративных сетей cisco catalyst 6800 также есть возможность модульного подключения extender’ов, которые, как мне показалось, обычные коммутаторы 2960 цвета хаки с немного урезанным IOS.

По умолчанию на всех extenders серии 2200 есть 4 порта 10г для подключения к основным устройствам. Есть два способа подключения nexus 2200:

1) Static pinning
2) Dynamic pinning

Static pinning
Основное отличие в том, что nexus 2200 так сказать делиться виртуально на несколько блоков, а именно на 4 блока, каждому блоку выделяться свой порт, который используется для передачи трафика управляющему устройству только для данного блока портов. Если, например, nexus 2200 подключается 2 портами к управляющему устройству, то порты делятся на 2 виртуальных блока. Если выходит из строя линк, который ответственен за данный блок то работать перестают все порты из этого блока. Принцип работы показан на рисунке:

static pinning

Настройка:

N5N(config)# feature fex

N5N(config)# fex 100

N5N(config-fex)# pinning max-links 2                   // указывается число аплинков до FEX

N5N(config-if)# interface port-channel100

N5N(config-if)# switchport mode fex-fabric

N5N(config-if)# fex associate 100

N5N(config-if)# vpc 100                                              //если используется технология vPC

N5N(config-if)# interface Ethernet1/1

N5N(config-if)# switchport mode fex-fabric

N5N(config-if)# fex associate 100

N5N(config-if)# channel-group 100

Проверка:

SD1-1-1-5-L3SW-246# sh fex 100

FEX: 100 Description: FEX0100   state: Online

FEX version: 7.0(4)N1(1) [Switch version: 7.0(4)N1(1)]

Extender Serial:

Extender Model: N2K-C2248TP-1GE,  Part No:

Pinning-mode: static    Max-links: 2

Fabric port for control traffic: Eth1/1

FCoE Admin: false

FCoE Oper: true

FCoE FEX AA Configured: false

Fabric interface state:

Po100 — Interface Up. State: Active

Eth1/1 — Interface Up. State: Active

Dynamic pinning
Как вы наверное уже догадались, порты, которые используются для подключения к управляющему устройству, распределяют свои ресурсы между всеми портами FEX устройства. В случае выхода из строя к примеру, двух кабелей трафик от устройств, подключённых к FEX будет передаваться по оставшимся двум портам. Пример работы, приведен на картинке:

dynamic pinning

Оба метода имеют свои особенности, как плюсы, так и минусы, но на мой взгляд все же лучше использовать 2 вариант. Кстати совсем забыл предупредить о важной особенности которую можно увидеть после настройки динамического pinning, а именно то что в самом устройстве он продолжает отображаться Pinning-mode: static. Может конечно он считает port channel за один широкий порт и поэтому так отображает, а может и баг J.

Настройка:

N5N(config)# feature fex

N5N(config)# fex 100

N5N(config-if)# interface port-channel100

N5N(config-if)# switchport mode fex-fabric

N5N(config-if)# fex associate 100

N5N(config-if)# vpc 100                                              //если используется технология vPC

N5N(config-if)# interface Ethernet1/1

N5N(config-if)# switchport mode fex-fabric

N5N(config-if)# fex associate 100

N5N(config-if)# channel-group 100

Как видите настройка ничем особо не отличается, кроме команды pinning max-links 2, которую мы не используем если хотим, чтобы был dynamic pinning (по умолчанию pinning max-links имеет значение 1).

Проверка:

SD1-1-1-5-L3SW-246# sh fex 100

FEX: 100 Description: FEX0100   state: Online

FEX version: 7.0(4)N1(1) [Switch version: 7.0(4)N1(1)]

Extender Serial:

Extender Model: N2K-C2248TP-1GE,  Part No:

Pinning-mode: static    Max-links: 1

Fabric port for control traffic: Eth1/1

FCoE Admin: false

FCoE Oper: true

FCoE FEX AA Configured: false

Fabric interface state:

Po100 — Interface Up. State: Active

Eth1/1 — Interface Up. State: Active

На этом все! До новых встреч!

 

С уважением

Султанахметов Дмитрий

 

 


Комментарии:

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Можно использовать следующие HTML-теги и атрибуты: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Hide me
Получать регулярно свежие материалы, лабораторные и вебинары
Email Имя
Show me